LSAC requires Windows

The Law School Admission Council requires you to install the Omniform(R) plugin to fill in forms on their website, to apply to law schools. Unfortunately, this seems to require Active X, which requires Microsoft’s Internet Explorer. Internet Explorer isn’t updated for Mac anymore, and I wouldn’t install that buggy piece of crap anyway. Please, someone tell me that I don’t have to use IE to apply to law school…

UPDATE: After installing the Omniform plugin on my dad’s Windows computer, it became clear that Omniform has a plugin for Netscape/Firefox, so the problem was not Internet Explorer / Active X. The problem is that Omniform only works on Windows. *Bashes head against the wall* I don’t have a Windows computer at school, so I guess I’m going to have to pray that I have sufficient permissions to install Omniform on the Windows computers in the lounge. LSAC, Omniform, and Microsoft are all now all on my “naughty” list, they’re getting coal in their stockings for Christmas.

6 thoughts on “LSAC requires Windows

Leave a Reply